Computer not recognizing PM4

Post bug reports or anomolous operation here

Computer not recognizing PM4

Postby Ram » April 7th, 2011, 7:56 pm

Hi,
I have connected the USB device from the PM4 (attached to a model D) to a windows 7 (64 bit machine). Each time I plug in, it complains with: "USB device not recognized" and fails to recognize the PM4.

Has anyone else seen this issue? Anybody else attempting to run rowpro on a Windows 7 64bit machine?

Regards,
--Ram
Ram
Paddler
 
Posts: 4
Joined: April 7th, 2011, 7:51 pm

Re: Computer not recognizing PM4

Postby carlb » April 7th, 2011, 10:34 pm

Have you downloaded and installed the newest release of the C2 Utility?
http://www.concept2.com/us/service/software/c2u/default.asp

That might install drivers that you need.
carlb
1k Poster
 
Posts: 174
Joined: March 1st, 2009, 1:43 pm

Re: Computer not recognizing PM4

Postby Ram » April 7th, 2011, 11:55 pm

Yes, I installed this utility but no luck. The utility requires a USB connection to the update the firmware but it was unable to do so.
:cry:
Ram
Paddler
 
Posts: 4
Joined: April 7th, 2011, 7:51 pm

Re: Computer not recognizing PM4

Postby Citroen » April 8th, 2011, 3:36 am

There are no device drivers for a PM3/PM4 it appears to Windows as HID (human interface device) using Windows built in drivers. Do you have the Win7 plug'n'play service disabled?

Give Concept2 a call at 800.245.5676
User avatar
Citroen
SpamTeam
 
Posts: 3435
Joined: March 16th, 2006, 3:28 pm
Location: Basingstoke, UK

Re: Computer not recognizing PM4

Postby Ram » April 8th, 2011, 1:23 pm

Plug N Play is enabled. I called Concept2 and left a message for the tech. Hopefully they will figure this one out. Thanks for suggesting that I call them directly.
Ram
Paddler
 
Posts: 4
Joined: April 7th, 2011, 7:51 pm

Re: Computer not recognizing PM4

Postby Ram » April 8th, 2011, 2:36 pm

Will@concept2 helped me with fixing this issue. For some strange reason, Windows 7/64 bit on Vmware would not recognize PM4. So we upgraded the firmware on PM4 from the host machine to the latest version. Soon afterwards Windows recognized the device. Rowpro is also working now.
Ram
Paddler
 
Posts: 4
Joined: April 7th, 2011, 7:51 pm

Re: Computer not recognizing PM4

Postby BrianStaff » October 10th, 2012, 12:17 am

I have the same problem. In fact, my Windows 7 machine has said that the USB device is malfunctioning for a few months now.

How would I update the PM4 firmware if Windows does not recognize the device?

FWIW - I do have 6.5 version of the Logcard utility installed.

Brian
M 65 / 6'3" / 234lbs as of Feb 14, 2008...now 212
Started Rowing: 2/22/2008
Vancouver Rowing Club - Life Member(Rugby Section)
PB: 500m 1:44.0 2K 7:57.1 5K 20:58.7 30' 6866m
User avatar
BrianStaff
2k Poster
 
Posts: 220
Joined: February 14th, 2008, 2:20 pm
Location: Scottsdale, Arizona


Return to Bug Reports

Who is online

Users browsing this forum: No registered users and 1 guest