Uploaded results lose checkboxes - Won't clear duplicates

Post bug reports or anomolous operation here

Uploaded results lose checkboxes - Won't clear duplicates

Postby wildcardcis » January 3rd, 2017, 8:47 pm

I was uploading to the online log with Concept2 Utility 7.05.03. I was using both HID Omnikey 3121 and USB, and all was well. (I do some workouts on PM4s and some workouts on PM5s, so my workouts are on both formats.)

Then in the last couple of weeks the old results that were already uploaded regained their checkboxes, as if they had not been uploaded. I checked the Select All best, and uploaded. It took the new uploads, but it gave the "Duplicate Entry" error message for all the old uploads (which were already onlilne). And it did NOT clear out the checkboxes in the utility. So this happens every time I try to upload. The newest ones that are uploaded have not checkboxes, but the old ones have the checkboxes and the error message happens every time and the checkboxes do not go away.

This is happening both on the HID reader and on USB. It is exactly the same problem.

Is there anyway to get rid of the checkboxes on the old workouts? It seems to me that this is a bug and that if the workout is a duplicate -- that is, if it is already online -- it should remove the checkbox.

Thanks!
wildcardcis
Paddler
 
Posts: 1
Joined: January 3rd, 2017, 8:39 pm

Re: Uploaded results lose checkboxes - Won't clear duplicate

Postby Citroen » January 4th, 2017, 7:24 am

Use the contact link http://log.concept2.com/contact to report your logbook failure.
User avatar
Citroen
SpamTeam
 
Posts: 4694
Joined: March 16th, 2006, 3:28 pm
Location: Basingstoke, UK

Re: Uploaded results lose checkboxes - Won't clear duplicate

Postby tvcrider » January 9th, 2017, 6:00 pm

wildcardcis wrote:I was uploading to the online log with Concept2 Utility 7.05.03. I was using both HID Omnikey 3121 and USB, and all was well. (I do some workouts on PM4s and some workouts on PM5s, so my workouts are on both formats.)
Then in the last couple of weeks the old results that were already uploaded regained their checkboxes, as if they had not been uploaded. I checked the Select All best, and uploaded. It took the new uploads, but it gave the "Duplicate Entry" error message for all the old uploads (which were already onlilne). And it did NOT clear out the checkboxes in the utility. So this happens every time I try to upload. The newest ones that are uploaded have not checkboxes, but the old ones have the checkboxes and the error message happens every time and the checkboxes do not go away.
This is happening both on the HID reader and on USB. It is exactly the same problem.
Is there anyway to get rid of the checkboxes on the old workouts? It seems to me that this is a bug and that if the workout is a duplicate -- that is, if it is already online -- it should remove the checkbox.
Thanks!


I believe this can be fixed, but in a rather drastic way.
I had a similar problem using my 2016 Model D and PM5 with USB. Results prior to a specific date kept regaining their checked-boxes, as if they had not been upload, but they had. I did indeed contact C2 Customer Service. They asked me to send a copy of my log file, which I did. Regrettably they could not duplicate the problem and offered no solution. Well that's not technically correct. Since I still have the Omni-card reader from my prior 2003 Model D Erg, C2 indicated that they could send me a used PM4. Well that would defeat the purpose of moving to the 'improved' (my term) Model D with PM5, so I declined.

I eventually 'fixed' this issue myself. I used the latest C2 Utility to delete all my workouts prior to the date in question. You can find that under the "Manage Stored Results" option. Just make sure your on-line log is up-to-date prior to proceeding.

I'm a big fan of Concept 2 and I've been using their Ergs for 25 years, but I am not terribly pleased with my new Model D which was delivered in January 2016. It's had a host of issues, particularly with the PM5 (errors, power management, file corruption).
"The older I get, the better I was."
User avatar
tvcrider
Paddler
 
Posts: 16
Joined: December 18th, 2006, 11:47 am
Location: Binghamton, NY USA


Return to Bug Reports

Who is online

Users browsing this forum: No registered users and 3 guests