Can't install Concept2 Utility on Mac

Maintenance, accessories, operation. Anything to do with making your erg work.
Post Reply
Posts: 1
Joined: November 23rd, 2017, 9:34 am

Can't install Concept2 Utility on Mac

Post by sveena » November 23rd, 2017, 9:54 am

I'm running OSX 10.11.6. When I download the Concept2 Utility v7.08.03 and try to run it I get to the point of opening the .pkg and there's a dialog that says, “Concept2 Utility 7.08.03.pkg” is damaged and can’t be opened. You should eject the disk image. This was also the case with the prior version of the utility so I always ran the windows version on another computer, but now I'm wondering if there's a workaround so I can us my Mac. Has anyone else experienced this? I tried re-downloading the utility but got the same result. Any advice will be greatly appreciated.

1k Poster
Posts: 120
Joined: January 20th, 2012, 2:45 pm
Location: Near Santa Cruz, CA

Re: Can't install Concept2 Utility on Mac

Post by lcantey » November 23rd, 2017, 8:44 pm

I just downloaded and installed Concept2Utility70803.dmg with no issues after reading your post. Running macOS 10.13.1.

User avatar
Posts: 14
Joined: November 16th, 2017, 10:10 am
Location: Fishers, Indiana USA

Re: Can't install Concept2 Utility on Mac

Post by MrHollick » November 27th, 2017, 1:16 am

Sounds like your first step would be to run the update for your system software. I'm running 10.13.1 and have no trouble with the C2 Utility program.
Keep on Rowing! -

Post Reply