Mod.D/PM4 not communicating

Maintenance, accessories, operation. Anything to do with making your erg work.
Post Reply
PavelS
Paddler
Posts: 11
Joined: December 5th, 2010, 1:42 pm
Location: Prague, Czech Rep.
Contact:

Mod.D/PM4 not communicating

Post by PavelS » July 15th, 2018, 4:44 pm

Spooky thing.. today I woke up the erg/monitor, everything worked fine. I took off the PM4 monitor just to take picture of it in better light (to play with software that is able to "read" numbers on the photo - without success, probably due to monochromatic display), than put it back. Since then, the monitor does not communicate with the erg, or the sensor respectively. PM4 shows all fields OK, however it does not get the signal. The wire seems to be OK, so does the connector. To make things even more weird, it seems to me, that the erg still "charges" the monitor because even when I take out the battery pack it wakes up when I start erging - however giving no numbers. Any suggestions?

User avatar
Citroen
SpamTeam
Posts: 5415
Joined: March 16th, 2006, 3:28 pm
Location: Basingstoke, UK

Re: Mod.D/PM4 not communicating

Post by Citroen » July 16th, 2018, 3:04 am


PavelS
Paddler
Posts: 11
Joined: December 5th, 2010, 1:42 pm
Location: Prague, Czech Rep.
Contact:

Re: Mod.D/PM4 not communicating

Post by PavelS » July 16th, 2018, 2:13 pm

Citroen, thank you for your help. Unfortunately, the problem persists. I will try to switch the monitor/sensor with another erg to identify which one to blame.

User avatar
Carl Watts
Half Marathon Poster
Posts: 2869
Joined: January 8th, 2010, 4:35 pm
Location: NEW ZEALAND

Re: Mod.D/PM4 not communicating

Post by Carl Watts » July 17th, 2018, 2:57 am

The tach socket on the board can come loose or I have seen sockets cracked in half.

The cable of the pickup can also fail at the 90 degree plug that goes into the monitor.

Plugging in the monitor to another rower may help but be aware a loose socket can cause intermittent connection.
Carl Watts.
Age:51 Weight: 98kg Height:183cm
Concept 2 Monitor Service Technician & indoor rower.
http://log.concept2.com/profile/863525/log

PavelS
Paddler
Posts: 11
Joined: December 5th, 2010, 1:42 pm
Location: Prague, Czech Rep.
Contact:

Re: Mod.D/PM4 not communicating

Post by PavelS » July 21st, 2018, 10:03 am

Carl, thank you for your insight and tips.
This is what finally happened: I took the sensor and monitor from the erg I have at home and took it to indoor-rowing studio I run. I tried to switch them at another randomly chosen erg. It proved that PM4 was ok, sensor not. I called local C2 dealer to order a new sensor however did not reach them on the phone. I decided to take functioning combination of devices home from another erg, installing in it the problematic pair. From some reason it started to work without any problems. I have no idea what happened but I hope this “repair” will last. :D

Post Reply