USB Permission Error On OSX Mavericks

Post questions and issues with Concept2 PM3 SDK
Post Reply
jcl
Paddler
Posts: 29
Joined: August 27th, 2014, 12:37 am

USB Permission Error On OSX Mavericks

Post by jcl » August 27th, 2014, 10:56 pm

I am attempting to write some code to interact with a PM3/4 using Java and usb4java. Everything appears to setup correctly and it does identify the device fine, but when attempting to send commands I get the following permission error:

Code: Select all

javax.usb.UsbPlatformException: USB error 3: Unable to claim interface: Access denied (insufficient permissions)
	at org.usb4java.javax.ExceptionUtils.createPlatformException(ExceptionUtils.java:39)
	at org.usb4java.javax.AbstractDevice.claimInterface(AbstractDevice.java:430)
	at org.usb4java.javax.Interface.claim(Interface.java:102)
Assuming it was the code, I tried using pyrow and get a similar error:

Code: Select all

USBF:    1476.883    IOUSBHIDDriver(IOUSBHIDDriver)::RearmInterruptRead  returning error 0xe00002c0 (no such device), not issuing any reads to device
I am at a loss on how to proceed at this point. I tried the kext loading/unloading with no success and some other suggestions from google. Hoping someone has seen this before and might be able to provide some guidance.

Thanks!

schander
Paddler
Posts: 16
Joined: September 7th, 2009, 4:10 am

Re: USB Permission Error On OSX Mavericks

Post by schander » January 6th, 2017, 5:59 pm

I think you have to use the HIDAPI. For python there is:
https://github.com/apmorton/pyhidapi
I'm sure that there is something similar for java

Regards
Satpal

Post Reply