PM5 looses Bluetooth AND Ant+ connection

Post bug reports or anomolous operation here
cronix
Paddler
Posts: 3
Joined: July 1st, 2017, 6:12 am

PM5 looses Bluetooth AND Ant+ connection

Post by cronix » July 1st, 2017, 6:16 am

I don't know if this is a bug or that the PM5 is just badly designed. But my PM5 continuously looses both the Bluetooth (iPhone 7) and Ant+ (Garmin HRM) connection during a row.

Concept2 replaced my PM5; but that didn't really help since this happened twice already this week.

Not something that I expected after reading all reviews. Is it only me who experiences this (several times a week)?

User avatar
Carl Watts
Half Marathon Poster
Posts: 2847
Joined: January 8th, 2010, 4:35 pm
Location: NEW ZEALAND

Re: PM5 looses Bluetooth AND Ant+ connection

Post by Carl Watts » July 1st, 2017, 6:12 pm

Apparently the PM5 also dumps your ANT+ HR belt as you checkin to RowPro as well.

No such problems with the PM4, although it seems to "Forget" your belt from time to time and you need to then pair it again but once connected its solid for the whole row. Looses its marbles maybe once a month.

It's something you just need to remember to check first up because you cannot fix the connection once checked into RowPro.

Thankfully I have two of the second generation PM4's, one on each rower and there is no hurry to move to the PM5 with all the issues it still has.

All you can do is ensure its running the latest version of firmware that you can update using the utility here...

http://www.concept2.com/service/monitors/pm5/firmware
Carl Watts.
Age:51 Weight: 98kg Height:183cm
Concept 2 Monitor Service Technician & indoor rower.
http://log.concept2.com/profile/863525/log

cronix
Paddler
Posts: 3
Joined: July 1st, 2017, 6:12 am

Re: PM5 looses Bluetooth AND Ant+ connection

Post by cronix » July 2nd, 2017, 4:24 am

This must be a structural problem with the PM5 since I have now experienced it with 2 PM5 computers.

I have seen that there is a second revision of the PM5 too since it runs a separate build of the software? That revision is not available here in the Netherlands (I don't know why). But its very clear that the PM5 doesn't deliver what is promised.

I am running the latest software. But I guess the PM5 is just badly designed on a hardware level.

User avatar
Carl Watts
Half Marathon Poster
Posts: 2847
Joined: January 8th, 2010, 4:35 pm
Location: NEW ZEALAND

Re: PM5 looses Bluetooth AND Ant+ connection

Post by Carl Watts » July 2nd, 2017, 1:08 pm

Well spotted on the different firmware version, missed that.

Really I am very surprised the PM5 has so many issues but like you said it must be more on the hardware level because of the new revision of the PM5 already and the fact the core functionality of the PM5 has hardly changed from the PM4 that really was rock solid. Even really small suggestions for improvements on the next version of monitor did not get implemented.

Thought it would take two years for the PM5 to become really good, if you compare the first release of the PM3 firmware back in 2003, the PM3 really changed quite a lot in the background over several years and got pretty slick by the time it ceased production. Most of the PM3's that I see for service have never had a firmware update in their life, but the owners are not complaining.

Would suggest that those with a post 2008 version of the PM3/4 really look after it and hope it goes for another 5 years at least.
Carl Watts.
Age:51 Weight: 98kg Height:183cm
Concept 2 Monitor Service Technician & indoor rower.
http://log.concept2.com/profile/863525/log

cronix
Paddler
Posts: 3
Joined: July 1st, 2017, 6:12 am

Re: PM5 looses Bluetooth AND Ant+ connection

Post by cronix » July 4th, 2017, 6:12 pm

I am sending the whole thing back. I have been waiting for three days until both the factory and the Dutch reseller have the decency to get back to me. They clearly don't want to support me. No answer at all.

Two PM5 computers with the same bug. This thing is just not working as advertised. You cannot use Bluetooth and ANT+ with this badly designed computer.

Is this normal for Concept2 to leave customers on their own?

User avatar
c2jonw
5k Poster
Posts: 539
Joined: April 3rd, 2006, 1:08 pm

Re: PM5 looses Bluetooth AND Ant+ connection

Post by c2jonw » July 5th, 2017, 10:27 am

cronix- sorry about the problem and slow response to the issue. We are working through our Dutch dealer to get this resolved. There are a number of possible causes of your problem such as outside interference, new ios system, PM5 issues (which should be resolved in your latest monitor but a serial number would tell us for sure). Connecting multiple devices can be challenging because there are so many possible iterations and circumstances. Personally I use HR and Ergdata simultaneously with no issues. Are you pairing the HR to the PM5 first, and then turning the wireless on? That order seems to work best for me. C2JonW
67 year old living in Waterbury Center, Vermont, USA
Concept2 employee since 1980! and what a long, strange trip it's been......and retiring from C2 in October 2018!

Aks
Paddler
Posts: 23
Joined: January 13th, 2013, 3:13 pm

Re: PM5 looses Bluetooth AND Ant+ connection

Post by Aks » July 28th, 2017, 5:46 pm

This same thing is starting to happen to me. I had no problem for a year, and the past few weeks, I am loosing bluetooth connection to my iPhone and my Garmin HR.

Aks
Paddler
Posts: 23
Joined: January 13th, 2013, 3:13 pm

Re: PM5 looses Bluetooth AND Ant+ connection

Post by Aks » August 11th, 2017, 7:14 pm

PM5 is loosing bluetooth connection every session now. Sometimes after 10 minutes, sometimes after 20. I updated firmware today (beta version) in hopes that wold fix it. This Erg is just a year old. Any ideas?

I'll change the batteries incase that's the issue. But my old Erg the batteries would last for years. And it was obvious when they needed to be replaced.

Aks
Paddler
Posts: 23
Joined: January 13th, 2013, 3:13 pm

Re: PM5 looses Bluetooth AND Ant+ connection

Post by Aks » August 12th, 2017, 7:14 pm

So.. .I switched the batteries out, and was hopeful, but lost connection after 2 minutes.

Aks
Paddler
Posts: 23
Joined: January 13th, 2013, 3:13 pm

Re: PM5 looses Bluetooth AND Ant+ connection

Post by Aks » August 15th, 2017, 11:16 am

UPDATE -

Switched out the batteries in the PM5 and then rolled back the firmware to whatever was the last stable one... 22? Anyway, the beta firmware seemed to be the culprit.

Worked fine after that.

User avatar
Navelgarden
Paddler
Posts: 15
Joined: March 14th, 2016, 1:56 pm

Re: PM5 looses Bluetooth AND Ant+ connection

Post by Navelgarden » September 16th, 2017, 1:58 am

I was having that same issue. Even ordered a new HR monitor thinking that was the problem. I was excited to see a new firmware update released yesterday, and for the first 43 minutes everything seemed great... that's when the ErgData timer suddenly stopped on my iPhone screen and the HR connection was lost. So frustrating. Transferring the workout data from memory to the USB stick then caused the PM5 to freeze. I'm not sure what is going on, but I don't enjoy rowing as much as I used to with the constant headache of dealing with the computer on this thing. Maybe I'll try rolling the firmware back to when it was working like a dream.

mrramsey
Paddler
Posts: 5
Joined: February 16th, 2017, 10:58 am

Re: PM5 looses Bluetooth AND Ant+ connection

Post by mrramsey » September 20th, 2017, 3:48 pm

I have been plagued with the same issue. The ERG is a great machine but the hardware and software is killing me. So archaic feels 12 years old...or older. I just want something to work.

User avatar
MrHollick
Paddler
Posts: 14
Joined: November 16th, 2017, 10:10 am
Location: Fishers, Indiana USA
Contact:

Re: PM5 looses Bluetooth AND Ant+ connection

Post by MrHollick » November 16th, 2017, 2:00 pm

We seem to be having a similar problem in our local box. my two rowers at home work just fine but at the box 6 of the 8 rowers we have the ErgData app with just randomly freeze up.

I'm assuming that means it is losing connection with the PM5 as the PM5 continues logging the data from your row.

Its extremely frustrating when the iPhone app freezes in the middle of the row.
Keep on Rowing! - www.MrHollick.com
Image

Aks
Paddler
Posts: 23
Joined: January 13th, 2013, 3:13 pm

Re: PM5 looses Bluetooth AND Ant+ connection

Post by Aks » March 20th, 2018, 6:03 pm

I've been dealing with this issue for 6 months.(see above) I thought it was my phone (iPhone) so I upgraded. Still had issues. Worked with C2 people and never quite got anywhere.

Then I started thinking about the times it did work (mainly when I got the new phone, but didn't register it with the carrier)

What seems to be working for me is putting the phone in airplane mode and then making sure bluetooth is enabled. I think the issue has something to do with my carrier(?)... maybe too much interference where my rower is. It's fine with wifi and bluetooth enabled.

I would love to know if this works for you.

Dane
Paddler
Posts: 2
Joined: April 15th, 2018, 2:08 pm

Re: PM5 looses Bluetooth AND Ant+ connection

Post by Dane » April 15th, 2018, 2:24 pm

Aks wrote:I've been dealing with this issue for 6 months.(see above) I thought it was my phone (iPhone) so I upgraded. Still had issues. Worked with C2 people and never quite got anywhere.

Then I started thinking about the times it did work (mainly when I got the new phone, but didn't register it with the carrier)

What seems to be working for me is putting the phone in airplane mode and then making sure bluetooth is enabled. I think the issue has something to do with my carrier(?)... maybe too much interference where my rower is. It's fine with wifi and bluetooth enabled.

I would love to know if this works for you.
Hi,
I have encountered this problem when I’m trying to connect ErgData to pm5 monitor. I get the ergdata to recognize the pm5 id but the connection is not successfully activated. Pm5 monitor says that the connection is successful, but the ergdata doesn’t start zeroing the previous row. I never had any problems with pm5 monitor or machine. Previously I managed to get the connection right away. I have connected several other monitors to same account with no problems . I tried to think what could have happened and what did I change. Then I remembered that i left my iphone charging overnight and the IOS updated to new version 11.3.
I’m usually not in favor of updating and tuning things if they work. Now I have to find way to get ergdata details out when I’m rowing. Also the workouts would be nice to get them to ergdata. At least i get the workouts synchronized when I connect the pm5 to mac.

Is there coming some kind of firmware fix to this issue? I’m going to try next workout that airplane mode.

Pm5 monitor has firmware 159
Iphone 7s 11.3
Ergdata 1.3.5(2)

Post Reply