Page 1 of 1


Posted: December 5th, 2018, 7:43 pm
by RayOfSunshine
It has always worked fine until today. I started a 12k and it froze (saying it was looking to connect) few 100 meters in. I figured it was the internet connection. I started again... and, the same thing happened. I rowed without ergdata because I had to finish before lunch was over.

I checked and the internet connection was fine, the latest version of ergdata was on my phone, and the PM5 was also up to date. I ran the C2 Utility anyway.

I'll give it a go tomorrow. Hopefully, it will all be okay.

Re: ErgData

Posted: December 7th, 2018, 10:12 pm
by RayOfSunshine
ErgData shut off 12:44 into a 60' row. Ugh. Any good alternative apps?

Re: ErgData

Posted: December 8th, 2018, 4:29 am
by Citroen
You're more likely to get your problem noticed by Concept2 if you send an email to

Re: ErgData

Posted: December 16th, 2018, 3:09 pm
by bojam
No reason for ErgData to shutdown ... if you battery in your phone/tablet has enough power. You could try turning on the location on the app for ergData. Use a cable instead of Bluetooth. Is the firmware up to date on the PM? Are you running the latest version of ergData/

As to another app try boatcoach on android and painsled on iOs.

Re: ErgData

Posted: December 28th, 2018, 3:59 pm
by RayOfSunshine
I contacted C2 as Citreon suggested. We exchanged quite a few emails. They were able to fix the issue and released a new version of ErgData. All is well now.