Firmware files not found at selected path

Post bug reports or anomolous operation here
Post Reply
Posts: 2
Joined: August 19th, 2015, 1:31 pm

Firmware files not found at selected path

Post by Dietsdontworkuk » April 4th, 2019, 8:00 am

Hi all,

after some 4 years my usb that I record all my rows with at the gym finally died.

I backed up a week ago to my Mac and am now trying to restore a new usb from backup

The backup seems to be on my Mac but when I try it says "Firmware files not found at selected path”.

I have moved the backup folder to new locations and manually browsed for them but get the same message.

I have tried to open some of the files manually using the unarchiver and also Stuffit expander but both say “.bin files cannot be expanded”.

Can anyone help? 3 million m of pain on there I'd hate to lose it!

Posts: 1
Joined: June 17th, 2019, 7:34 pm

Re: Firmware files not found at selected path

Post by Johnno62 » June 17th, 2019, 7:42 pm

I had the same problem, error on my PM5 (something to do with batteries) which then corrupted my USB Stick which has 4,000,000m worth of workouts!

Had an error on my PM5 last week, something related to the battery cover (which I've ordered the revised version of) and this corrupted my faithful old USB stick.

I reformatted the USB stick and got the same error when trying to restore from back up.

I ended up initiating the USB stick again via the Utility, then copy/replace the 'LogDataAccessTbl.bin' and 'LogDataStorage.bin' files from my last successful backup.

I backup once per week, but I'm also getting the 'Firmware files not found at selected path' error when I try to restore using the utility. I lost about a weeks worth of workouts, but back in action again and I'll back up after every workout now. Considering just using a smartphone app that saves directly to online log.

I've reformatted the USB stick and started from scratch, but would like to restore all the old workouts. Saved all my workouts to the online log, but the PM5 readout from the usb stick is just a little reminder every time I get on the rower of how far I've come!

Maybe it's time to change to a smart phone app and log directly online??
Last edited by Citroen on June 18th, 2019, 4:55 am, edited 1 time in total.
Reason: Merged duplicate posts.

User avatar
Posts: 6751
Joined: March 16th, 2006, 3:28 pm
Location: A small cave in deepest darkest Basingstoke, UK

Re: Firmware files not found at selected path

Post by Citroen » June 18th, 2019, 4:56 am

Open your email client. Write an email to They won't see this in this backwater of the forum.

Then download the latest firmware and install it on your PM5.

Then download Ergdata onto your phone.

Post Reply