ErgData fine during use then fails to record data

Topics relating to online racing and training with 3rd party software.
MPx
2k Poster
Posts: 375
Joined: October 30th, 2016, 1:38 pm
Location: Somerset, UK

Re: ErgData fine during use then fails to record data

Post by MPx » August 19th, 2019, 8:31 am

Its happened just twice to me in 8 months. I've found if I move the workout from PM5 to a USB stick and upload it from the stick to my C2 Online Log, then the next time I sync Ergdata on the phone the workout copies back across to the iPhone 6s without issue. So all my physical databases are the same and complete.
Mike - 62 HWT 183

Image

Ernits
Paddler
Posts: 15
Joined: June 1st, 2019, 10:36 am

Re: ErgData fine during use then fails to record data

Post by Ernits » August 24th, 2019, 12:55 am

It is a shame that uploading from USB stick doesn't get you the graphs Ergdata does :|

canglem
500m Poster
Posts: 64
Joined: April 23rd, 2019, 10:48 am

Re: ErgData fine during use then fails to record data

Post by canglem » August 24th, 2019, 9:20 pm

This has happened to me twice this week. I can’t remember if the first time I did this, but tonight I for sure started the workout by selecting “ReRow”. Can any of you remember if you started the workout this way?

canglem
500m Poster
Posts: 64
Joined: April 23rd, 2019, 10:48 am

Re: ErgData fine during use then fails to record data

Post by canglem » August 25th, 2019, 6:30 pm

canglem wrote:
August 24th, 2019, 9:20 pm
This has happened to me twice this week. I can’t remember if the first time I did this, but tonight I for sure started the workout by selecting “ReRow”. Can any of you remember if you started the workout this way?
Disregard this. Started a new workout today, programmed in brand new distance, and immediately upon finishing the last meter, the error popped up on my phone. So I've had it happen starting a 2k from the pre-programmed workouts, a Re-Row workout and a new workout. I will send an e-mail just so they have another record of it.

bobtherower
Paddler
Posts: 35
Joined: August 19th, 2019, 4:50 am

Re: ErgData fine during use then fails to record data

Post by bobtherower » September 6th, 2019, 10:21 am

Happened to me again today (15km workout, Rerow)

User avatar
Citroen
SpamTeam
Posts: 5977
Joined: March 16th, 2006, 3:28 pm
Location: Basingstoke, UK

Re: ErgData fine during use then fails to record data

Post by Citroen » September 6th, 2019, 1:06 pm

Update the PM5 firmware, update your version of Ergdata. If you're doing "Just row" workouts you must ALWAYS press the [BACK] button when you're done or the PM5 won't record it.

If it still fails write an email to rowing@concept2.com with your symptoms.

skraburski
Paddler
Posts: 12
Joined: April 9th, 2019, 2:43 am

Re: ErgData fine during use then fails to record data

Post by skraburski » September 6th, 2019, 3:10 pm

This is what Concept2 support sent to me:

Thank you for contacting Concept2 about this. This sounds like a recent bug in the iOS version of ErgData. This is a bug that we hope to have fixed soon with an update to the ErgData app. In the meantime there is a beta version of the app that you can use.

Please follow this link to install the beta version of the ErgData app: https://testflight.apple.com/join/MKCJFWnf

I've tried beta today and it worked fine. Hopefully will be ok on next trainings.

User avatar
deadwood
Paddler
Posts: 3
Joined: August 26th, 2011, 9:07 am

Re: ErgData fine during use then fails to record data

Post by deadwood » November 5th, 2019, 8:25 pm

I have been experiencing a similar problem. I have tried to the beta-version referenced in an earlier reply. It had been working fine, but I experienced my first failure to record a workout today.

User avatar
deadwood
Paddler
Posts: 3
Joined: August 26th, 2011, 9:07 am

Re: ErgData fine during use then fails to record data

Post by deadwood » November 5th, 2019, 9:35 pm

This is what Concept2 support sent to me:

Thank you for contacting Concept2 about this. This sounds like a recent bug in the iOS version of ErgData. This is a bug that we hope to have fixed soon with an update to the ErgData app. In the meantime there is a beta version of the app that you can use.

Please follow this link to install the beta version of the ErgData app: https://testflight.apple.com/join/MKCJFWnf

I've tried beta today and it worked fine. Hopefully will be ok on next trainings.
I have experienced similar issues. The beta version seemed to be working better however today it did fail to save one of my workouts.

skraburski
Paddler
Posts: 12
Joined: April 9th, 2019, 2:43 am

Re: ErgData fine during use then fails to record data

Post by skraburski » November 6th, 2019, 1:46 am

I've been using beta successfully almost for 2 months. I think I had one crush when using ErgData and spotify at the same time. Just in case I'm manually killing all other apps on the phone, and since I started that I had no issue with ErgData loosing connection with PM5.

User avatar
deadwood
Paddler
Posts: 3
Joined: August 26th, 2011, 9:07 am

Re: ErgData fine during use then fails to record data

Post by deadwood » November 6th, 2019, 9:22 am

skraburski wrote:
November 6th, 2019, 1:46 am
I've been using beta successfully almost for 2 months. I think I had one crush when using ErgData and spotify at the same time. Just in case I'm manually killing all other apps on the phone, and since I started that I had no issue with ErgData loosing connection with PM5.
Thanks....I will try it without any apps running. I typically have spotify running while I am rowing.

-DW

dllarson
Paddler
Posts: 9
Joined: October 24th, 2019, 11:27 am

Re: ErgData fine during use then fails to record data

Post by dllarson » November 29th, 2019, 3:30 pm

I first posted this under bugs in support then I saw this topic which seems just like my problem.

The ErgData app didn't record and upload my BikeErg data.

I first SkiErg'ed 3km with my phone connected to the SkiErg. When done I disconnected ErgData from the SkiErg PM5 and connected it to the BikeErg's PM5. All looked just fine as a rode "Just Bike" 7km+. All the bike data and my heart rate monitor were updated during the ride in ErgData all the way to the end. I then hit the "Menu" button to finish the workout. Everything seemed to finish fine. I hit sync and the data (I thought from both machines at the time) seemed to be uploaded just fine.

Later when I checked the C2 Logbook the BikeErg data was missing. Looking on my phone it was missing there too. This was kinda upsetting as the distance is for the holiday challenge!

I looked on the PM5 and saw the workout in memory. So I took a USB stick that was already set for my account and copied the workout to the USB stick. Then I used the Concept2 Utility upload the workout to the logbook. But wait! The utility won't let click the checkbox to upload that workout! This is probably for keep non-verified data from the logbook?

So failing all these things I manually entered the workout data into the logbook in the hopes it will count toward the challenge. The holiday challenge seems to count the manually entered data but I'm concerned these may be culled at some point.

I'm not sure what I screwed up in my procedures but I surely don't want it to happen again! :shock:

Does anyone see what I did wrong here?

-Dale

adombek
Paddler
Posts: 1
Joined: November 29th, 2019, 3:46 pm

Re: ErgData fine during use then fails to record data

Post by adombek » November 29th, 2019, 3:51 pm

Hi Dale,

The current AppStore version of ErgData has a few bugs related to saving workouts.
A new version should be out in a week or so with fixes.
If you want to try the beta now, you can get it here:
https://testflight.apple.com/join/MKCJFWnf

Regarding your issue with the Concept2 Utility, are you sure you were logged into your online log account prior to trying to upload the workout?

Regards,
Andrew

dllarson
Paddler
Posts: 9
Joined: October 24th, 2019, 11:27 am

Re: ErgData fine during use then fails to record data

Post by dllarson » November 30th, 2019, 12:10 pm

Hi Andrew,
Regarding your issue with the Concept2 Utility, are you sure you were logged into your online log account prior to trying to upload the workout?
Yes I believe so because it had a logout field on the table of workouts. I actually tried logging out and then back in and the results are the same. Perhaps it had something to do with originally initializing the USB stick on my Rower and then using on the BikeErg?

Thanks for the link to the beta software but I'm running on Android. I see that I didn't mention that on my posting. My bad.

I'm going to try the rower and follow with the BikeErg today. I'll pay closer attention to details this time in case it happens again.

-Dale

User avatar
Citroen
SpamTeam
Posts: 5977
Joined: March 16th, 2006, 3:28 pm
Location: Basingstoke, UK

Re: ErgData fine during use then fails to record data

Post by Citroen » November 30th, 2019, 12:18 pm

Logout and log back in on Ergdata.
viewtopic.php?p=480061#p480061

Post Reply